allanswers.org - FAQ: Sun Computer Administration Frequently Asked Questions

 Home >  Computers and Hardware >

FAQ: Sun Computer Administration Frequently Asked Questions

Section 1 of 5 - Prev - Next
All sections - 1 - 2 - 3 - 4 - 5


Archive-name: comp-sys-sun-faq
Last-modified: 1998/7/6
Version: 1.9.30

Frequently Asked Questions for Comp.sys.sun.admin

Last update July  6, 1998

This is a collection of common questions posted to the comp.sys.sun.*
hierarchy.

Please send corrections or submissions to "Rob_Montjoy@ececs.uc.edu". 
Mark the Subject as Sun FAQ. Remember lets make this a better FAQ and
that requires submissions and corrections so if you have
an answer to a nontrival question send it to me.

This FAQ is available from ftp.ececs.uc.edu (129.137.8.4)
in the /pub/sun-faq/FAQs. Get the file sun-faq.general.

Also, ftp.ececs.uc.edu mirrors the FSF/GNU stuff from prep.ai.mit.edu
and is available as ftp.ececs.uc.edu:/pub/gnu

Finally, ftp.ececs.uc.edu mirrors the security directory off ftp.uu.net
as ftp.ececs.uc.edu:/pub/security


Other FAQ's that you should check are as follows:


	Sun Hardware FAQ edited by James W. Birdsall 
			ftp://ftp.ececs.uc.edu/pub/sun-faq/FAQs/Hardware/

	Sun Managers FAQ edited by John DiMarco  
			ftp://ftp.cdf.toronto.edu/pub/sun-managers/faq

	Sun CD-ROM FAQ edited by Mike Frisch 
		http://saturn.tlug.org/suncdfaq

	Solaris2.x FAQ edited by Casper Dik 
	   	An HTML version is available from
			http://www.wins.uva.nl/pub/solaris/solaris2/
		A mirror of Casper's directory is available from
			ftp.ececs.uc.edu:/pub/sun-faq/FAQs/mirrors/Solaris2
		which includes the autoinstall pieces.

	Solaris2.x Porting FAQ by David Meyer 
		ftp://ftp.ececs.uc.edu/pub/sun-faq/FAQs/Solaris2.x-Porting-Hints

	Solbourne Computer information available provided 
		by Stephen Dowdy dowdy@cs.colorado.edu  via
			http://www.cs.colorado.edu/~dowdy/Solbourne

	A SunOS 4.x Modem Tutorial is available from
		http://www.stokely.com/unix.serial.port.resources/tutorials.html
	and a PPP/SLIP info for SunOS is available from
		http://www.stokely.com/unix.serial.port.resources/ppp.slip.html
	Both of these pages have been created by Celeste Stokely 
		celeste@stokely.com
 

	 	
	Finally, you can check at my "alpha" version of a Sun
	related Web page at http://www.ececs.uc.edu/SunInfo/sun-tips.html

I try to keep these up to date copies of all these files in 
	~ftp/pub/sun-faq/FAQs on ftp.ececs.uc.edu (129.137.8.4)



Notes:	As of this writing almost all of these questions apply
      	to SunOS versions up to 4.1.4. SunOS 5.x questions
      	will start appearing gradually as more people start
      	installing SunOS 5.x (Solaris 2.x). 

	I am looking for suggestions on how to split this FAQ into
	sections. These sections should follow the comp.sys.sun.* 
	newsgroups(app, hardware, admin, misc, and wanted) and
	section on bettering Sun Security. Basically, what
	will end up with is a FAQ on each subject. Each
	FAQ will have a Solaris1.x Section, a Solaris2x section,
	and a section common to both.

	I will probably need some volunteers to help coordinate
	this undertaking.. Send suggestion to the usual address.

	Some of these questions are out of date and need updating
	when I get the time (or maybe a little birdie will do it for
	me) I will update them. Thanks.


This article includes answers to the following questions, which are loosely
grouped into categories. Questions marked with a '+' indicate questions
new to this issue; those with significant changes of content since the 
last issue are marked by '!'.


				Questions

 1)! 	How to get DNS working when not running NIS ?
 2)   	How to get DNS to be used when running NIS ?
 3) 	How to properly setup NFS mounting of /var/spool/mail ?
 4)!   	Can I use AnswerBook under X11R5?
 5)     What does "NFS write error X" mean?
 6)! 	How do I find the amount of memory installed or other
	system configuration information?
 7)     Where can I get a version of ftp that does logging?
 8) 	Where can one get SunOS patches? Where can I get patch 10xxxx-xx?
 9)    	How to setup Openwindows Calendar Manager in a distributed
	environment?
10)  	Why does the talk command fail between SunOS
	and any other manufacturer's equipment (like DEC)? 
11)   	How do I setup "anonymous" ftp?
12)     How come yppasswdd does not automatically update the yp maps?
13)     What does NFS getattr failed/RPC: Authentication error mean?
14)     Why did my Quantum 105 megabyte hard disk stop working?
15)     Can I replace the 105 megabyte internal drive with a higher capacity
        model?
16)     How can I turn my Sun3 into an X-Terminal?
17)	Why is my console login prompt garbled or in some strange 
	alphabet after upgrading to 4.1.3?
18)  	Why are the "random" missing services at boot time or any other time
	(even though the services are in the /etc/services file or NIS map)?
19) 	Where can I get Data Certified tapes for 4-mm or 8-mm tape drives 
	(at reasonable price)?
20)   	What is "archie"?
21)! 	How do I synchronize time on my Network?
22)  	What is the phone number for Sun Express and other numbers of importance
	to Sun Users? 
23)!  	How do I join sun related  mailing lists?
24)  	How do I use Mac floppies in a SUN drive?
25) 	How can I transfer floppies back and forth between MS-DOS and Sparc?
26)	Why is my biff not "biffing" when using biff in a networked
	environment?
27) 	How do I disable L1-A(STOP-A) or re-map it?
28)  	Why are all the local users "unknown" when using sendmail under 4.1.2?
29)! 	What are the dump parameters for an exabyte 8200 or 8500?
30)! 	What are the guidelines for setting up swap space ?
31)	What are the general guidelines for maxusers to be set to on machine X?
32)	What does "zsN: silo overflow" mean?
33)	What does the "N" in "zsN: silo overflow", and other "zsN" messages,
	signify?
34)	How do I set up a Sun serial port both for dial-in and dial-out?
35)	I can't get my Sun, running SunOS 4.1[.x], to establish a UUCP
	connection to some non-Sun machine; it won't log in.  What's wrong?
36)! 	Do the Sun serial ports support RTS/CTS flow control?
37)	How do I specify that a serial port should, or should not, ignore the
	state of the Carrier Detect line?
38)	I put in a new "termcap" entry, or updated an existing "termcap" entry,
	for a terminal, but "vi" doesn't seem to know about my change.  Why?
39)	I have a Type 5 keyboard, and find its placement of the Caps Lock,
	Control, and Esc keys inconvenient.  How do I remedy this?
40)  	How can I move keys around on a Sun keyboard, for example exchanging the
	Caps Lock and Control keys on a Type 5 keyboard?
41)   	My Sun doesn't have an ANSI C compiler.  How can I get one?
42)  	How do I change the time zone setting on my machine?
43)	I'm getting messages that say one of the following:
	 	proc: table is full	and/or
        	file: table is full	and/or
        	dquot: table is full 	and/or
        	inode: table is full
     	What do these errors mean, and how do I fix the problem?
44)  	Blank at present.
45)!  	How do I run X11R5 applications under Openwindows or Openwindows 
	applications under X11R5?
46)  	Where do I find a "restricted" shell for SunOS?
47)!   	Will SunOS 4.1.x binaries run under SunOS 5.x?
48) 	When I try to compile MITs X11R4 applications under Openwindows 3.0,
	I get the following "undefined" symbols(_get_wmShellWidgetClass, and
	_get_applicationShellWidgetClass). What is the Problem?
49)!   	What is Solaris?
50)     What does the "nres_gethostbyaddr !=" error mean?
51)! 	How come my mouse only works in the vertical(or horizontal) direction,
        how do I repair it?
52) 	After rebuilding the shared library libc it get some or all the 
	following undefined symbols: dlsym, dlopen, dlclose mbstowcs_xccs,
			mbtowc_xccs,wcstombs_xccs, or wctomb_xccs.
53) 	What does "No network locking on host" mean after upgrading to
	Solaris 2.0?
54) 	Does Password Aging work with NIS(YP) ?
55) 	What does "rpc.lockd: Cannot contact status monitor!" mean?
56)	How do I join the Sun User Group(SUG)?
57)    	How do I increase the number of "pseudo" terminals(ptys) ?
58)  	Where are dump and restore under Solaris 2.x?
59)  	How do I make the numeric keypad on a type 5 keyboard work with xterm?
60)   	How do I swap the CAPS LOCK and CONTROL keys on a type 5 keyboard 
	under Openwindows 3.0?
61)!   	Which Sun models run which versions of SunOS?
62)  	My rdump is failing with a "Protocol botched" message. What do I do?
63)!    Table of Solaris2.x commands and their Solaris1.x equivalents?
64) 	How do I setup DNS on Solaris2.x?
65)    	Can a SPARCclassic or LX run SunOS 4.1.3?
66)  	I just restored my root partation and now I can not boot. What
	is wrong?
67)  	How do I disable/enable packet forwarding?
68)  	How do I disable the printing of banners pages?
69)  	How do I change my hostname?
70)     Table of Solaris2.x files and their Solaris1.x equivalents?
71)! 	Where can I get the BSD print spooler for Solaris2.x?	 
72)!	Where is the Solaris2.x screenblank?
73)!  	Is there a command to display the configuration of 
	currently attached SCSI devices?
74) 	My printer will not print large files(over 1-megabyte), I 
	keep getting "file to big" errors. What do I do?
75)!  	I keep getting "data corruption" when using NFS over a wan,
	or slip/ppp link. What do I do? 
76) 	Does anybody know how to enable UDP checksum on NFS?
77)  	Is there a mailing list for Wabi?
78)  	Are there any public domain Multi-Vendor backup management
        systems?
79) 	How to determine the revision of SuperSPARC processor.
80) 	How do I install SunOS4.1.x by hand (off a CD)?
81)	Why won't my SUN207 (Maxtor LXT213) hard drive work in
        my SPARCstation 10/xx?
82)! 	I'm running SunOS/4.1.x and every time I try to format my
    	new 9GB SCSI disk I get "format failed" messages -- what's
    	broke, and how can I fix it?
83)!   	I can not get my new Exabyte 8505 (or others) working under
     	SunOS (or Solaris) What to do ?
84)  	The keyboard keeps stop working after exiting X or Openwin.
	What to do?
85)!  	How do I re-build the kernel under SunOS4.x?
86)  	How do I hook up a HP(or other) Desktop SCANNER?
87)!  	How do I find which process has a file open?
88)   	How do I create a partition greater than 2-gig on SunOS4.1.x?
89)   	Why do I keep having to answer the question 
	"CLEAN FLAG IN SUPERBLOCK IS WRONG; Fix?" when running fsck on
	an active filesystem?
90) 	Are dynamically linked setuid executables insecure?
91) 	How do I change the default router under Solaris1.x or Solaris2.x?
92) 	What is the difference between the Domestic vs International version
	of SunOS 4.1.x?
93) 	Where can I get the latest version of TOP?
94) 	Can I run the SX card in a Sun running SunOS4.1.x?
95) 	I just changed my shell to tcsh(or pick a favorite) and
	get  "530 User xyzz access denied" when ftping into this 
	machine. What is the problem?
96)	How do I put several dump images on one tape?
97) 	Can I "dump" the whole disk to tape in one command?
	(even with several slices/partitions)
98)! 	Where do I get software for my HP JetDirect Ethernet Card?
99) 	I do not know the root password, What do I do?
100)  	Where do I find a POP server for Solaris or SunOS?
101) 	How do I clear Stale NFS Filehandles?
102)! 	How can I use the same ethernet interface for two different IP networks?
103)! 	Where do I get CAP for Solaris (or SunOS 4.1.x)?
104) 	Where do I get DOOM for Solaris (or SunOS 4.1.x)?
105)	Why does "dump/ufsdump" tell me it is rewinding the tape even
	when I specified the "no rewind" device?
106)	How can you I speed up filesystem restores and/or copies?
107) 	I just added a new device (ie harddisk) to Solaris I have rebooted
	but the system still can not find it. What do I do?
108)	I need to change the broadcast address from all 0's to 1's
	or where to set the broadcast address under SunOS4.x?








				Answers

 1) 	How to get DNS working when not running NIS ?

	Note: Solaris2.x users should see question 64..
	
        The "normal" behavior of a hostname lookup under NIS is to
        consult the NIS hosts map and then DNS (if configured). If
	you are not running NIS the system will only look in 
	the /etc/hosts file. 

	You have two options to correct this situation:

		A) Re-build the shared library version of libc with replacement
		   resolver routines which understand DNS. Resolv+ provides one
	           of the best sets of replacement routines and it is easy
		   to install. Resolv+ can be obtained from

		   	ftp.ececs.uc.edu:/pub/sun-faq/Source/resolv+2.1.1.tar.Z

		   If you install resolv+ make sure that you setup your
		   /etc/hosts.conf . /etc/hosts.conf should contain something
		   like this:
  			order    bind hosts
  			multi    off
  			nospoof  on

		   Another option to use is bind-4.9.3 or later
		   which is available from

			ftp://ftp.vix.com/pub/bind/release/

		   However, the bind shared libraries will ignore /etc/hosts
		   and do all lookups via DNS.


		   Rebuilding the shared library will not allow  statically
		   linked binaries to do name resolving and these binaries
		   will only use /etc/hosts. "Dynamically linked"
		   replacements for mount and rcp are available from

	   		ftp.ececs.uc.edu:/pub/sun-faq/Source/rcp-mount.dyn.tar.Z

		   This file only contains sun4 binaries. A Sun 3 binary
		   for mount can be retrieved from

	   		ftp.ececs.uc.edu:/pub/sun-faq/Source/mount.sun3.Z
		
		   To be able to rebuild shared libraries you need to 
		   install the "shlib custom" option which is available
		   with SunOS version 4.1 or greater. 

        	   You can still use NIS for other things in environment,
	           such as passwd, and group maps.

		B) Run NIS with the "hosts" maps only. If you 
		   only need DNS capability than change the "all"
		   line /var/yp/Makefile to "all:  hosts".  

		   It does not require any changes to shared libraries.
		
		   See question 2 for complete directions on how to setup
		   DNS with NIS.

	Last Updated:  July 3, 1996.
 
 2) 	How to get DNS to be used when running NIS ?

	First setup your /etc/resolv.conf file.

	Use this file as a template.

	;
	; Data file for a client.
	;
	domain		ececs.uc.edu		; local domain 
	nameserver	129.137.8.118		; primary domain nameserver
	nameserver	129.137.32.101		; secondary domain nameserver 

	Where:	"local domain" is the domain part of the hostnames.
		 For example, if your hostname is "ftp.ececs.uc.edu"
		 your "local domain" is "ececs.uc.edu" or you could use
		"uc.edu". 

	Verify using nslookup that you are now resolving names
	via DNS. Try something like "nslookup ftp.uu.net" and
	see if you get back the IP address.

	You will need to put a copy of this resolv.conf on
	all NIS servers including slaves.

	After you have the /etc/resolv.conf setup and working do 
	the following:

	Under SunOS 4.1 and greater, at the top of the /var/yp/Makefile
 	uncomment the "B=-b" line and comment using the "#" sign the "B=" 

	If you are running 4.0.x you will need to edit the
	/var/yp/Makefile or apply the following "diff":

*** Makefile.orig       Wed Jan 10 13:22:11 1990
--- Makefile    Wed Jan 10 13:22:01 1990
***************
*** 63 ****
!                   | $(MAKEDBM) - $(YPDBDIR)/$(DOM)/hosts.byname; \
--- 63 ----
!                   | $(MAKEDBM) -b - $(YPDBDIR)/$(DOM)/hosts.byname; \
***************
*** 66 ****
!                   | $(MAKEDBM) - $(YPDBDIR)/$(DOM)/hosts.byaddr; \
--- 66 ----
!                   | $(MAKEDBM) -b - $(YPDBDIR)/$(DOM)/hosts.byaddr; \

	Now setup NIS in the usual fashion (ypinit -m ) or if your "brave"
	and have already setup NIS just re-make the hosts map. Something
	like this should work remove /var/yp/hosts.time, cd /var/yp, 
	and type make (i.e. cd /var/yp; /bin/rm -f hosts.time ; make).

	You will need reboot the machine or restart ypserv for these changes
	to take affect.

	The manpage for ypserv incorrectly states that you need to
	start ypserv with the -d option to get DNS to work with NIS.
	The manpage is incorrect -d option is for debugging.

	If you need a copy of the NIS Makefile look in /usr/lib (NIS.Makefile).
	Or grab the Makefile from ftp.ececs.uc.edu:/pub/sun-faq/Makefile.nis

	Last Updated:  July 20, 1995.

 
 3)	How to properly setup NFS mounting of /var/spool/mail ?

	On the Client machines:

		A) mount /var/spool/mail with the no attribute caching
		   option.
		
		   An example, fstab line would be the following:

		   mailhost:/var/spool/mail /var/spool/mail nfs rw,noac 0 0

		B) Use a sendmail.cf that forces all mail to be delivered
		   by the mailhost. 

		   One such file is available via anonymous ftp to 
		   ftp.ececs.uc.edu. Get the file 

				/pub/sun-faq/sendmail.client.cf

		   Do not use the OR option that Sun provides. It is broken
		   in many ways.

	On the server machine:
	
		A) Setup DNS MX records pointing to the mailhost for
		   all client machines.

		B) Edit the /etc/exports file to export /var/spool/mail
		   to the mail client machines. You may want
		   to use a netgroup for this purpose.

		C) Setup the /etc/sendmail.cf on the server recognize
		   that mail to/from a client is "local".

		   One such file is available via anonymous ftp to 
		   ftp.ececs.uc.edu. Get the file 

				/pub/sun-faq/sendmail.server.cf
		
	Note: 	You may want to install Berkeley sendmail instead of Suns
		stock sendmail. 



 4) 	Can I use AnswerBook under X11R5(6)?

	AnswerBook in its current form requires the Openwindows
	server. It uses the NeWS/Display Postscript extensions
	to this server to display the Answerbook files.

	To use AnswerBook under X11R5 you will need to replace the 
	docviewer program with program that calls Ghostscript to view
	these pages.  A replacement docviewer can downloaded from
	ftp.ececs.uc.edu (129.137.8.99) as /pub/sun-faq/Source/docviewer.tar.gz
	This kit contains more than one  docviewer. Try using
	the one in the toplevel docviewer directory.

	This replacement docviewer does not support all the options that
 	the "real" docviewer supports such as "hypertext" links.

	To install the replacement "docviewer" you will also need 
	Ghostscript 2.4 or above and Ghostview 1.3 or above both of
 	which are available from prep.ai.mit.edu in the /pub/gnu directory.

	This replacement docviewer is reported to work with all versions
	of AnswerBook but not as well as the original :).


	Note: The Solaris 2.6 documentation can be accessed via the web
	at: docs.sun.com
	
	Last Updated:  Apr 25, 1998.
	

 5)     What does "NFS write error X" mean?

        You can lookup the error codes in /usr/include/sys/errno.h.

        Two common NFS error codes are 13 - "permission denied" and 70 -
        "stale file handle".

	Error code 13 can occur from incorrect /etc/exports entry. Also,
	it can occur because someone has changed the /etc/exports
	entry to disallow the client after the client has already
	been granted permission to perform this operation.

        Error code 70 occurs when the file handle on the
	NFS server changes for a particular filesystem.
	The "file handle" can be changed under the following
	circumstances:
		
		A) Installing a new drive in place of an old.

		B) Moving a filesystem from one devices to
		   another.

		C) Performing a format, newfs, dump, and restore
		   cycle. Even if to the same device.

		D) Unmounting a file system without remounting it.

		E) Unmounting a High Sierra/ISO 9660 CD-ROM and
	           mounting a different CD.

        You can usually get rid of the error by unmounting and
        remounting the filesystem in question. 

	Also, error code 70 can occur when someone removes a file 
	that a process is actively writing from a NFS client machine.

        Under SunOS 4.1, you can run "showfh" to translate the NFS
        "file handle" given in the error message into a Unix pathname.
        Beware that showfhd does a "find" on your server to get the
        filename.  "man 2 intro" will give you some more general
        information on what error codes could mean.

	You will need a patch to get "showfh" to work correctly. The patch
	id is 100371 and this patch is required for 4.1, 4.1.1, and 4.1.2.
	This patch has been integrated into 4.1.3.

 6)	How do I find the amount of memory installed or other
	system configuration information?

	You can use the "devinfo" command to find out general information 
	about the hardware attached to your Sun. The "devinfo" command is 
        only available on desktop SPARCsystems, SPARCengine 1E (although not
        in the version used in Auspex systems), or 600MP series server only.

	Also, most sparc clones should support devinfo.  Any machine that has
	an SBus will probably support "devinfo" but any machine that doesn't 
	have an SBus probably won't support "devinfo".

	Note in Solaris "devinfo" is called "prtconf" and all options
	are the same. 
	
	The "best" command for determining system information is  
	"sysinfo". Sysinfo is available from

		ftp://usc.edu/pub/sysinfo/

	Sysinfo works on all Sun architectures (including Sun-3s) and all
	SunOS and Solaris releases as well as many other UNIX boxes such
	as Ultrix, and Next. 

	Also, you can use the sundiag to find out configuration information
	as follows:

		/usr/diag/sundiag/sundiag -wv 
		/bin/cat /usr/adm/sundiaglog/sundiag.conf | /bin/sort

	Finally, the "dmesg" command can be used to get memory information.
	Try something like "dmesg | grep -i memory". It may not return
	any memory information if the system has been up for a while.

	Note:  "wc -l /dev/mem" and "dd if=/dev/mem of=/dev/null" and 
               the like will *not* give the correct answer on machines 
	       where physical memory is not contiguous, such as many Suns.

	OpenWindows 3.3 and above also support the "wsinfo" command, which
	provides some of this information, in particular memory size.

	Last Updated:  May 23, 1996.


 7)     Where can I get a version of ftp that does logging?

	Get the wuarchive ftp daemon from

        	ftp://wuarchive.wustl.edu/packages/wuarchive-ftpd

	A version of the wuarchive ftpd daemon that compiles right out
	of the box for Solaris2.x machines can be had from
	ftp.ececs.uc.edu (129.137.8.4) in the /pub/sun-faq directory.
	Remember to specify your own paths in the src/pathnames.h file.

	The stock Sun ftpd will log some information if you add the "-l"
       	flag in /etc/inetd.conf:

        	ftp stream tcp nowait root /usr/etc/in.ftpd in.ftpd -l

        Also enable syslogd by adding:

        daemon.info      /var/adm/syslog

        to "/etc/syslog.conf".

	Last Updated:  Oct 25, 1995.


 8)     Where can one get SunOS patches? Where can I get patch 10xxxx-xx?

        Many anonymous ftp sites have partial collections of patches.
        These sites include the following:
	
	Sun sanctioned sites:
		sunsolve1.sun.com:/pub/patches/
    			via WWW http://sunsolve1.sun.com/
		sunsite.unc.edu:/pub/sun-info/sun-patches/
    		sunsite.unc.edu:/pub/sun-info/sun-patches/
    		sunsite.sut.ac.jp:/pub/sun-info/sun-us/sun-patches/
    		sunsite.doc.ic.ac.uk:/sun/sunsite-sun-info/sun-patches/

	Note: You should always attempt to find a local site before
	      using the above.

	sunsolve1.sun.com contains a collection of recommended and 
	security patches. Be sure to check out the 2.x_Recommended.tar.Z
	files which contain all the Recommended patches in  one file.
	The "Sunsites" are essentially mirrors of sunsolve.

	Support Customers:

    	Starting with SunSolve CD 2.1.2 ALL Sun patches are shipped
    	on the SunSolve CD.

    	Support customers can get all patches via ftp from Sunsolve
    	or by e-mail and query one of the online sunsolve-databases
    	on the internet.

	Some notes:	

	Do install the Recommended patches. 

	If you find a bug report it to Sun. This is the only way
	it will get fixed.

	Do not "blindly" install all patches. Sun does not always
	have time to test for possible interactions between patches.

	Do not install patches for applications that you do not use.

	Do install patches for "bugs" that are actually affecting you.

	Last Updated:  Feb 2, 1998.


 9)	How to setup Openwindows Calendar Manager in a distributed
	environment?

	Sun's original assumption that each user has a permanent machine 
	allocated to them is not applicable in most environments. Just as 
	users send mail to 'user' rather than 'user@machine', users want 
	to browse others user's calendars and do not care or want to know
	where the calendar is actually stored.

	Here is procedure to accomplish our goal. All calendars
	will be stored on a central server. The initial setup
	must be done on the server.

		A) Have the user login to the calendar host(calhost)
		   machine.
		
		B) Change everyone's .cm.rc file so that 
		   Calendar.DefaultCal points to user@calhost

		   calhost can be an hostname alias or an actual
		   hostname. You may want to use the alias
		   just in case you change the "calhost" later.
	
		C) Change their Access List and Permissions (under
	           Edit/Properties) to show user@client with BID (browse,
	           insert, delete) permissions for any client machine the
		   user wanted to access their calendar from.

	Notes: If you use the scheme you should not NFS mount 
	       /var/spool/calendar on the client machines.

	or

	You can install the "Proxy OpenWindows Calendar Manager", which
	is available via anonymous FTP from ftp.ececs.uc.edu in
	/pub/sun-faq/proxy-cmsd.tar.Z.

	or
	
	You can install the "new cm daemon" which allows you to access
	several Calendar hosts at once. It implements the "original"
	rpc.cmsd daemon semantics(unlike proxy-cmsd) and thus all
	the features(of CM) will work as documented.  The latest source
	for this daemon was available via anonymous FTP from
	ftp.amdahl.com (129.212.11.1) in the  /pub/newcm_d directory
	but alas it is no longer but you can still get a copy from
	from ftp.ececs.uc.edu as /pub/sun-faq/newcm_d-1.3.tar.Z

	As of this writing newcm is being ported to Solaris2.x.

10) 	Why does the talk command fail between SunOS
	and any other manufacturer's equipment(like DEC)? 

	SunOS and Solaris use the old BSD 4.2 version of talk. 
	The old talk uses "machine dependent" byte ordering. Since
	DEC has different byte order the two talks can not
	communicate (even if you use "otalk" on the DEC
	machines).
	
	Also, most vendors have the newer version of 
	talk from BSD-4.3 and this version is not compatible
	with the Sun Version which is BSD-4.2.

	The solution is to get and install the new version
	of talk because it uses "network" byte ordering and
	it is compatible with most Vendors current talk 
	implementations.
	
	"New Talk" is available via anonymous ftp from 

		ftp.ececs.uc.edu:/pub/sun-faq/Source/ntalk.tar.gz

	This contains a version of new talk that compiles on
	both Solaris and SunOS. The Solaris version does not
	require the Berkeley compatability libraries.
	
	Finally, a program called Ytalk can be used with either
	"New talk" or "Old talk" and compiles on all versions
	of SunOS (including 5.x).

	Ytalk can be obtained from 

		ftp.ececs.uc.edu:/pub/sun-faq/Source/ytalk-3.2.tar.gz

	Last Updated:  November 12, 1995

11)	How do I setup "anonymous" ftp?
	
        Read the man page ftpd(8) in the SunOS 4.x documentation, as 
        the procedure differs from vanilla BSD and most examples in 
        system administration books. 

	The "ls" binary is dynamically linked, requiring you to 
	duplicate ld.so, libc.so.* and /dev/zero in the ftp area.
	The permissions and ownership of the files within the 
        ftp area are critical to having a secure configuration.
	
	Note: For SunOS versions 4.1.2 and 4.1.3 you will need
	      to copy /usr/lib/libdl.so.* to the ftp area as well.

	You can use a "statically" linked binary from the GNU
	fileutils instead of the "dynamically" linked SunOS
	version. You can get the GNU fileutils from prep.ai.mit.edu
	in the directory /pub/gnu

	There is also a statically linked version of ls for Suns
	running SunOS 4.1.x, available via anonymous ftp from
	ftp.ececs.uc.edu.  Get the file /pub/sun-faq/ls.statically-linked
	or get it from the SunOS install CD in the "tools" directory.

	A complete procedure to setup anonymous under SunOS is
	available via anonymous ftp to ftp.ececs.uc.edu. Get
	the file /pub/sun-faq/anon-ftp.how-to.

	There is an _excellent_ script written by Peter N. Lewis
	(peter.lewis@info.curtin.edu.au) for setting up anonymous ftp
	located on ftp.ececs.uc.edu, in the file /pub/sun-faq/anon-ftp.scrpt

12)     How come yppasswdd does not automatically update the yp maps?

        There is a bug in 4.1 rpc.yppasswdd that causes it misinterpret
        the command line arguments.  A work-around is to add the
        "-nosingle" flag (which is the default), this shifts the
        arguments over one, so "passwd" is read instead of "-m".
	Also, you should use the complete path to rpc.yppasswdd

        For example:

        /usr/etc/rpc.yppasswdd /var/yp/passwd -nosingle -m passwd DIR=/var/yp

	Note: Only use the DIR=/var/yp if your source files for passwd, group,
	      etc are in /var/yp. If they are in /etc you do not need
              to and should not specify the DIR= parameter.

	Also, you can modify the NIS Makefile to change to the location
	of the maps (ie modify DIR= in /var/yp/Makefile). Than you
	could use something like this instead of the above line:

		/usr/etc/yppasswdd /var/yp/maps/passwd -noshell -m passwd

	This assumes that all NIS text/source files are in 
		/var/yp/maps
            
        If you are running the C2 security package, you should apply
        the C2 Jumbo patch, as it fixes several problems with rpc.yppasswdd
	and rpc.pwdauthd. The patch number is

	100201-04 or greater for SunOS 4.1 and 4.1.1
	100564-06 or greater for SunOS 4.1.2 and 4.1.3

	Last Updated:  April 27, 1995.

13)     What does NFS getattr failed/RPC: Authentication error mean?

        You are probably running a pre-SunOS 4.0 version of NFS and your
        username is in more than 8 groups.  There is a limit on the
        number of groups that could be represented in the rpc service
        (called NGRPS).  On pre-4.0 systems this was 8, now it is 16.
        Since many vendors other than Sun are still running old versions
        of NFS, you might see this error even if your SunOS is recent.

        Authentication errors are also caused by having secure RPC
        enabled on the client but not on the server, or by having a
        misconfigured secure RPC configuration for the user name
        generating the errors.  Beware of this problem when you are
        using the automounter, as programs (such as Sendmail) may
        silently fail when when they try to mount a directory
        and get this error.

	Last Updated:  Feb 23, 1998.


14)     Why did my Quantum 105 megabyte hard disk stop working?

	This the now infamous Quantum drive "stickation" problem.

Section 1 of 5 - Prev - Next
All sections - 1 - 2 - 3 - 4 - 5

Back to category Computers and Hardware - Use Smart Search
Home - Smart Search - About the project - Feedback

© allanswers.org | Terms of use

LiveInternet